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Foreword 

The 3Data Expert 14.1: Tutorial 1 - Working with 3D Models document introduces 
the basic 3D model handling with 3Data Expert 14.1: 3D model viewing, 
measuring, repair, splitting, connecting, adding lap joint, hollowing, drain hole 
generation, Boolean operations, support generation, surface triangulation, data 
reduction and separating shells for different material or color definitions in one part.  

DeskArtes 3Data Expert 14.1 is available as a 64-bit implementation, allowing you 
to handle huge models for Additive Manufacturing.  

The full tutorial set for 3Data Expert contains several documents which cover 
different aspects of model repair, coloring and print preparation. The tutorials are 
available in the software distribution package through the Help > Tutorial 
Documents menu:  

⚫ 3Data Expert 14.1: Quick Start Guide gives a short introduction to model 
repair and splitting for 3D Printing with 3Data. Estimated completion time 
15 minutes. 

⚫ 3Data Expert 14.1: Tutorial 1 - Working with 3D Models introduces basic 
viewing, measuring, automatic repair, split, connect, hollow, offset, 3D Text, 
Boolean, cut, reduce, 3D nesting, surface triangulation and other model 
manipulation functions available for STL files. Estimated completion time is 
3 hours.  

⚫ 3Data Expert 14.1: Tutorial 2 – Working with Colors introduces basic 
automatic repair and coloring for 3D Color Printer users. Estimated 
completion time is 1 hour.  

⚫ 3Data Expert 14.1: Tutorial 3 – Separating Shells describes the use of Shell 
Separation commands in 3Data Expert. These commands enable 
separating a part into several shells for different material (shore value) or 
color definitions in a single part. This tutorial is meant only for users who 
have a Base module license. Estimated completion time is 30 minutes.  

⚫ 3Data Expert 14.1: Tutorial 4 – Generating Supports for AM explains the 
use of new Generic Supports command and Sand Supports command. The 
support generator can be used to generate supports for DLP, metal, 
stereolithography and sand-based processes. Adding extra connectors to 
prevent parts from warping and bending during the build is explained. Also, 
new slicing, slice preview and slice filling is demonstrated. Estimated 
completion time 1 hour.  

⚫ 3Data Expert 14.1: STL and VRML repair examples document includes 
more advanced model repair operations with 3Data Expert. Estimated 
completion time with 3Data Expert 2 hours.  

The tutorial documents and the geometry files for the tutorial examples are found 
in the Tutorials folder and its sub-folders (GeomFiles, Tutorial 1, Tutorial 2, etc.) in 
the 3Data Expert installation directory.  
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Additional information and help on other STL manipulation tools can be found in 
the Handling Faceted Files section of the On-line Help pages. These pages contain 
information on verifying, repairing, splitting, offsetting, hollowing and draft checking 
for tooling applications.  

The operations given in boldface in this document are commands which affect the 
geometry of the part in question or are otherwise important and must be run by the 
user in the given order to get the results show in this document. Several other 
commands, like viewing and clipping, are not given in boldface but should be used 
to enable generation of a correct result. Terms given in italics refer to file names, 
commands, shell names, surface names and parameters for different commands.  

The pictures in this document can differ from the version you get. Most of the 
pictures have been grabbed with the classic theme, while the dark theme has been 
used for some of them. The theme can be changed from Edit > Preferences. 

Modules 

The lessons in this tutorial are organized in such a way that that the required 
software functions increase along the lessons. 

DeskArtes 3Data Expert software suite consists of several products targeted from 
home and DIY use to education and professional Additive Manufacturing: 

− 3Data Expert Free is an entry level tool targeted for viewing, verifying, 
repairing, dimensioning, and communicating 3D geometry information. It 
allows you to input triangle models, create consistent topology, check 
errors, orient normal vectors, repair gaps and self-intersections, edit 
triangles and output STL data for 3D printing, without any cost. In the 
tutorials, when information relevant to the Free module is handled, it is 
marked with  

− AM Expert module (an option to Free and Base) provides automatic AM 
process selection based on part requirements (material, size, accuracy, 
tensile strength, and post processing). The AM Expert database currently 
contains data for 129 professional AM systems, and it is regularly updated.  

− 3Data Expert Dimensions is a simple, economical, and user-friendly tool for 
STL repair and 3D model splitting for machines with a smaller build area. 
The tools include Repair, Splitting and Connect with Pins or Lap Joint. 
Information relevant to Dimensions will be marked with .  

− 3Data Expert Lite includes all standard 3D model preparation tools for 3D 
Printing and Additive Manufacturing. Available tools include geometry 
generation, Boolean and 3D markup commands, Offset, Hollowing, 
Coloring and Texturing, Solidify (aka “shrink wrap”), as well as Slicing and 
Tool compensation. Optional 3D Nesting makes 3Data Expert Lite a perfect 
3D data preparation tool for powder-based AM systems. Information related 
to Lite will be marked with .  
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− 3Data Expert Base is a professional tool for preparing 3D models for 
Additive Manufacturing and Simulation applications. There are several 
commands for manipulation of both 3D surface models and 3D faceted 
models. These commands include Surface triangulation, STL verification 
and repair, STL Offsetting, Splitting, Connecting, Decimation, Smoothing, 
Solidify, Boolean, Part subdivision, 3D Nesting, Z Compensation, Slicing 
and Tool Compensation as well as STL Coloring and Texturing. Supports 
can be generated for DLP, metal and stereolithography processes. Special 
Sand Support command creates supporting plates for delicate sand parts 
with a push of a button. Information relevant to Base is marked with . 
However, most of the tutorial contents are applicable with Base.  

− 3Data Expert Color ( ) contains a subset of 3Data Expert Base, 
especially meant for handling color models. A variety of color and texture 
specific input formats are handled: VRML, ZPR, 3DS, OBJ, PLY. 3Data 
Expert Color has previously been labeled as DeskArtes 3DEdit Pro. 
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Lesson 1 – Basic User Interface properties 

This lesson shows you how to do basic file input, viewing, dimensioning and 
verification of surface data with 3Data Expert. 

You will need a license to go through the lessons except the ones marked with  
Before starting the lessons, please make sure you have received and installed the 
software evaluation license from DeskArtes. If you do not have a license yet, it is 
very simple to request a license. First start the DeskArtes 3Data Expert (or 
Dimensions Expert, etc.) by double-clicking on the icon created on the desktop 
during the installation.  

 

Then go to the Program licenses dialog through Help > Licenses command. There 
you can find the Request evaluation license on-line button.  

 

Press it and it will open the DeskArtes license request page on your favorite web 
browser. Fill in the required fields and press Submit evaluation request button to 
send the license request to DeskArtes. 
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You will receive the 15-day evaluation license within 24 hours.  

When the license arrives, press the Install license code button and Copy/Paste the 
license string into the input field: 

 

Then press OK to accept the license. Finally, restart the software. Now you are 
ready to go ahead with the lessons! 

If you wish to install network licenses, please have a look at the On-line Help (Help 
> Help Topics command) page Installation / Licenses section. 

If you have used 3Data Expert 14.1 earlier in your computer you may want to delete 
the settings file (settings3DE141.das) in your AppData folder: open Windows 
Explorer, type “%APPDATA%\DeskArtes” into the address field, locate the settings 
files and delete it, finally restart the program. This initializes the system into its 
basic state and ensures that your results will not differ from the lesson results. 
Please see the On-line Help Installation / Settings page for the location of the 
settings file. 
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The Free module  

Some of the functionality of 3Data Expert does not require a license: you can input 
several faceted file formats (STL, PLY, ZPR, VRML, …), create topology for the 
model, check errors, repair 3D models automatically and manually, as well as 
output the checked data for 3D Printing (STL, VRML, PLY, ZPR). For more serious 
repair work and model manipulation, like split, connect, hollow, drain hole, support 
structure generation etc., a suitable license is required.  

Sandbox mode exceptions 

Certain 3Data Expert functions, like Drain Hole and Hatch Supports, are created 
using a separate background process started from 3Data Expert. In this case some 
antivirus software products may try to restrict the background process executable 
into “Sandbox” mode. This will cause the command to fail. To fix the problem set 
an exception for the background process executable. This is normally done 
through the antivirus software interface where you can change the run mode from 
“Sandbox” to “Normal”.  

File input 

You can start the 3Data Expert by clicking on the icon created on the desktop 
during the installation. If no desktop icon is created, use the Windows Start menu 
to search and launch the software.  

 

After starting the system and closing the Message dialogs you will see the basic 
configuration of the 3Data Expert on your screen: menus, different toolbars, and 
the graphics area. Initially, the menus of the Base module are shown. You can, 
however, change between menu setups if you wish to see less commands (like 
hiding those you don’t have a license to run); also, in 3Data Expert Base, you can 
switch between Build Setup and Advanced Editing modes: 
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File input is normally done File > Open command (which deletes any existing 
models from program memory), or you can drag a geometry file into the graphics 
area (which actually performs the File > Insert command). 1 

− Start the File > Open and select the Tutorials / GeomFiles folder 
under the software installation directory. 

The file type is chosen from the Files of type dropdown list.  

− Select type STL files (*.stl) and you will see the list of STL files in the 
GeomFiles directory. 

− Select slubox-gap.stl from the file list and press the Open button.  

 

After a while you should see the slubox geometry on your screen.  

 
1 For both file input and output, there are options which can be controlled via File > File Options. 
These will be discussed later. 
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When a model is inputted 3Data Expert allows to check and set the units to the 
part. For example, STL files do not have any unit information in them.  

 - Press OK to accept the proposed units, millimeters (mm).  

 

You will next be prompted for the Operation Mode2. 3Data Expert has six main 
operation modes: Fix, Modify, Position, Print, Color and View mode. You may have 
a different set of Modes available depending on which module you are running. 

 

The different modes are used for different tasks: 

⚫ Fix takes you to automatic model verification and repair and contains 
shortcuts to the main tools used for repair work. 

⚫ Modify lets you change the model geometry with features which are 
necessary or useful for production. 

⚫ Position contains tools which help you optimize the positioning of 
components on the printing platform.  

⚫ Print shows tools for preparing a repaired and positioned model for your AM 
printer, such as creating support structures and slicing. 

⚫ Color displays the tools for painting and texture image addition. This mode 
also checks the model for errors when selected and sets the display into 
“what you see is what you get” display color mode. 

⚫ View Mode allows you to temporarily view the model and then return to 
Operation Mode selection later (or to close the minimized window). 

You can also simply close the Operation Mode via the top-right close button. 

 
2 In Edit > Preferences, you can turn off automatic features, including the Operation Mode display. 
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The normal way to begin repairing a model is to start with the Fix mode. To start 
fixing  

− press the Fix button (the leftmost one) in the Operation Mode dialog. 

3Data Expert will begin automatic model verification (Fix Model > Verify Shells 
command). The screen is erased, and a progress bar appears. When the analysis 
is ready, Auto Repair dialog with Model status message is displayed: 

 
You will also see the model structure in the Model Tree on the left-hand side of the 
graphics area (see the image below). The model is divided into separate shells 
during verification. In this case we only get one shell (1. slubox-gap (Verified)). The 
shell has errors (i.e. gaps), which is indicated by the red icon in the Model Tree; 
correct shells would have green icons with  or without  a warning sign 
(depending on defined warning settings), non-verified shells with yellow icons . 

The Model status message indicates that there is one verified shell, which contains 
errors. The display shows red Gap curves through the surfaces. You can use the 
viewing commands when the Auto Repair dialog is visible, zoom (mouse wheel) 
and pan (Ctrl + left mouse button) if you cannot see the gap.  

On the right-hand side of the graphics area, you will see the Tools Window. Fix 
Tab on the Tools Window provides shortcuts to the commands available for repair, 
like Repair Shells and Fill Gaps commands. The Help text window at the lower part 
of the Tools Window also contains information useful for the required repair 
actions.   

Auto Repair is normally the best path to follow when repairing 3D models. The 
different parameters for Auto Repair are set automatically, you should normally 
accept them as they are. We will later see examples where the automatically set 
parameter values are changed. Anyhow, this time we are not going for immediate 
full repair (this is done in the Quick Start Guide), instead we will investigate the 
Model Tree, the Tools Window, and the selection mechanisms available in the 
software. 

 - Press No (in the red circle) to start viewing the model.  
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A status window appears: 

 

− Press OK to continue to see the Tip Window with useful tips on viewing 
and selection mechanisms. 

 

− After reading the tip you can Close the window. You may also prevent 
it from displaying in the future by ticking off the User Interface > Show 
Command Tips setting.  

 

Workspace and Print Configuration  

When you open a file in 3Data Expert, a workspace, as defined in the current Print 
configuration is automatically added to the model and shown in the graphics 
window. When opening the slubox-gap.stl, you get a warning: 
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This happens because the slubox-gap model does not fit in the workspace in the 
x- and y-directions. Press OK to see the model in the workspace. 
The workspace is not needed for the lessons in this tutorial, so you can hide it 

using the View > Show Platform command (or the  icon). You can also hide 

the bounding box with the  icon and change to shaded view with  icon.  

After closing the Tip Window, you will see the model in the graphics area: 

 

The model icon is red to indicate that it has errors (gaps). The different colors of 
the object (pink and blue) on the graphics area are caused by the gap (drawn as 
a red curve in the model). Through the gap we can see inside the part. In the 
default Repair color mode, the outside (normal side) of the surfaces is displayed 
with pink color and the inside (inverted normal side) is displayed with blue color. 

Model Tree 

On the left-hand side of the 3Data Expert window you can see the Model Tree. 

 

In the current contents you can see one shell, 1. 
slubox-gap (Verified). The shell icon is red 
indicating errors in the model. The (Verified) text 
indicates the last command run on the model. 
Above the tree you can see a line of context-
dependent buttons. Three buttons are always 
visible: collapse tree, view/hide object, and fit 
object. 

 

Below the Model Tree you can see information 
about the selected part, for example the number 
of triangles, part extents, volume, as well as the 
original file name and path.  
We will later take a more careful look at the 
contents of the Model Tree. 
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If you need more screen space for the graphics window, you can press F8 to 
open and close the Model Tree window.  

Basic viewing commands 

Try the following commands to become familiar with viewing operations. Note that 
the commands below do not alter the model’s true 3D coordinates. They only alter 
the eye-point location:  

⚫ Rotate the model on the screen by pressing the middle mouse (MMB) and 
moving the cursor. MMB rotation is always available. Left mouse button 
(LMB) rotation is available most of the time except when working with 
painting, texturing, curve editing, and transformations. However, LMB is 
mostly used for selecting objects as shown later. In case you do not have 
3-button mouse, you can also use key combination Ctrl + Shift + LMB or 
Ctrl + Shift + mouse wheel (MoW) 

⚫ Rotate the model around a selected surface point by pressing the right 
mouse button (RMB) and moving the cursor. A blue cross indicating the 
rotation middle point appears on the part surface if the cursor is on top of 
the model when the RMB is pressed.  

⚫ Pan the model by dragging with the Shift + MMB (or LMB most of the time) 
(Shift + MMB means pressing the Shift key and dragging with the mouse). 
For panning, you can also use Shift + MoW. 

⚫ Pan with rubberband by dragging with Shift + RMB. 

⚫ Zoom in/out by rotating the MoW. 

⚫ Zoom in/out with Ctrl + MMB (or Ctrl + LMB).  

⚫ Zoom to box with Ctrl + RMB.  

⚫ Hide all by pressing the  icon with LMB (or F5) 

⚫ Show all by pressing the  icon with LMB (or F6) 

⚫ Fit the model by pressing the  icon with LMB (or F7). 

The main viewing command icons reside in the Viewing Toolbar: 

 

Try them out now. The tooltips provide a short description of each icon. Let the 
cursor remain on top of the icon for a short while to see the tooltip: 

 

Also, the Viewing Planes x/y/z toolbar above allows you to select any projection 
direction as the viewing direction: 
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You can show the green selection box around the selected object by pressing the 
Show Bounding box icon in the Viewing Toolbar: 

 

Try also Clipping functionality through 
the Clipping Tab to look inside the model. 

The Clipping Tab is opened with the     
icon. The clipped area can be displayed 
in different ways, like as wireframe or 
transparent.  

Clipping also enables to extract real time 
slice information from the model. Real 
time slices can be copied to the Model 
Tree for internal model dimensioning with 
the Edit > Save Clip curves command.  

 

 

Selecting objects 

Object selection can be done either from the display area or from the Model Tree. 
Erase the screen and then display the object node “1. slubox-gap (Verified)” 
again by clicking it in the Model Tree. Now we have done one selection at the shell 
level. This level can also be called as the part or component level, depending on 
the context. Click on the little box with the '+' icon besides the part name. The result 
should look like below: 

 

The node “1. slubox-gap (Verified)” has 
opened and shows the contents of the shell. 
Each shell consists of several leaves, 
surfaces (1. Verified, ...), which all together 
make up the whole list. Triangle surfaces are 
identified with the  icon. An STL model is 
subdivided into separate surfaces along sharp 
edges during the Verify operation, as done 
earlier.  
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Select surface number 3 from the model tree by clicking it with the left mouse 
button (LMB). You can see one of the surfaces displayed with a green Bounding 
Box around it. Now this surface is your current selection (make sure the bounding 

box display is set with the  button.  

The selected surface is also highlighted on the screen: 

 

The model contains errors, one gap. The gap data is also located in the Model 
Tree after the surfaces. Similarly, gaps can be selected from the Model Tree for 
different operations, like Fill Gap command (to be done later).  

 

Selecting shells, surfaces and triangles graphically 

You can also select shells or surfaces from the display area by pointing with the 
left mouse button (LMB). First  

− display the Tools Window by pressing Shift+F8 (if not already 
visible): 
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The Tools Window includes shortcuts to 
frequently used repair, coloring and print 
preparation tools as well as Help text to aid 
with the repair work. You will later learn 
more about the use of the Tools Window.  

In the following we will use the Selection 
mode buttons to set the Selection Mode to 
correct level.  

You can use Shift + F8 to open and close 
the Tools Window. 

 

 

 

The selection is done with the left mouse button (LMB), and the selection target is 
controlled by the Selection mode buttons in the Tools Window:  

 

The four Selection mode buttons refer to (from left to right) selecting the whole 
model, one shell, one surface, one gap/triangle. Now try to select a shell from the 
display area, such as the “1. slubox-gap (Verified)”. 

If the Selection mode is not Shell (which is the default) press the  button to 
turn on Shell selection. Then click on the model with LMB and the shell will be 
selected. 

Then set the Selection Mode to Surfaces with  and click with LMB on 
surface 3 which now gets selected. If you wish to select objects behind surface 3 
just re-click with LMB (without moving the mouse. Instead of LMB, you can use the 
SPACE key, also without moving the mouse (this can help especially if mouse 
movement causes problems with a high-resolution display). 

Then press the  button to turn on the Gap selection and click close to the gap 
on the graphics area to have it selected in the Model Tree. 

Note: Triangle selection mode is available through the Color tab, and it is reserved for painting 
the model; please see “Tutorial 2 – Working with Colors” for more information. Otherwise, 
triangles are selected and manipulated through Fix Model > Edit Triangles command.  
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Multiple selection can be done by pressing the Ctrl key down while selecting 
objects from the graphical area or from the Model Tree with the LMB. The Shift key 
can be used to select objects between the first selection and the latest selection in 
the Model Tree. Different combinations Alt, Shift, Ctrl + LMB on the graphics area 
create, add and delete objects from the multi-selection, please see Online Help 
page Selection / Selecting objects. Multiple selection can be used with several 
commands, like Transformation or Fix Model menu commands.  

Display Area menu 

The right mouse button (RMB) has a special meaning on the display area.  

− Press the Surface selection mode button  again. 

− Clicking the RMB on top of a displayed object now brings up the 
Display Area Menu (not available in Triangle/Gap selection mode): 

When you click the RMB on the model while 
in Surface selection mode the surface which 
is nearest to the cursor is indicated on the 
first menu item.  

− Click RMB on top of surface 3 
again. 

− With the Next/Previous command 
you can indicate surfaces which are 
behind surface 3 along the line of 
sight at the mouse position.  

You can also change the shading and 
visibility of the selected object with the 
commands in the menu. If you wish to select 
the indicated surface, press Select. 

 

The 1487: OK triangle entry in the RMB menu indicates the input number of the 
triangle below the cursor. If this menu item is selected, more information about the 
triangle is displayed. This can be helpful especially when working with triangles 
with errors.  

The RMB menu of the graphics area is shorter in other modes than Surface 
selection and, for example, in Shell selection gives the name of the shell at the 
mouse location as the first item.  

A similar popup menu is available on the Model Tree with the RMB click, please 
try that too. 

Object properties 

Information about the properties of the currently selected object is given to the user 
in two different ways.  
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The basic information about the current selection 
is given below the Model Tree window. Much of 
the information is same as in the Object 
properties dialog (as explained below), but the 
information is structured in a different manner. 
There are also differences, like shell history 
which is shown more clearly in this list. 

 

There are three places to display the Selected 
Object Properties:  

• The menu command View > Object 
Properties or  

• the Model Tree RMB popup menu 
command Properties item  

• or the Display Area popup Menu 
Properties  

The Object Properties window contains a couple 
of items which are not available in the 
information below the Model Tree, for example 
the options to temporarily choose the object’s 
display color, and at root level, change the unit 
of the model. 

 

The exact position of the part is given as bounding box values both in the 
information field and the Object Properties window. Also, the extents, volume and 
the surface area of the object are calculated.  

Note: with this example the Volume is not correct. This is because the model is not solid. The 
Volume is reliable with Repaired faceted models without gaps and for surface models with 
consistently oriented surface normal. The Area value is always valid both for surfaces and 
faceted models. 

 

Dimensions and Annotations 

For communication and documentation purposes it is often important to include 
dimensions and annotations to be stored with the model. The Dimensions menu 
gives us the tools to add dimension information to the model. 

 - Set Shell Selection mode with the  shortcut button. 

Measuring and annotation tools can be started from the Dimensions menu or 
through the toolbar: 
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If the toolbar is not visible,  

− give command User Interface > Toolbars > Dimensions Toolbar. 

Let's first take an absolute point value from the slubox-gap model.  

− Rotate and zoom the model so that you can see it as shown here (you 
can also change the viewing and clipping during the dimensioning to get 
a good view of what you are measuring): 

 

 - Give command Dimensions > Point Value (the  icon) .  

The Crosshair icon is shown on the display area and the program is waiting for you 
to select a point on the model for coordinate values. Select one point from the 
model and you will see a result like below (cropped): 

 

 

Let's now try distance between two points. This is done with 

− command Dimensions > Distance or the  icon. 

After you give the command, you will see a new Crosshair icon. The number 1 
beside the crosshair icon tells you that it is waiting for the first point for the point 
distance evaluation. Now select the first point and the second point (crosshair with 
number 2 beside it) so that the result would look like the one on the previous image. 
Press RMB to accept or ESC to quit or cancel a selected point. 
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In the same way you can take Angle and Radius using the Dimension menu. Try 
to repeat the example shown on the next page. Keep in mind that you can Zoom, 
Pan and Move the eye point using the mouse and keyboard shortcuts. Dimensions 
> Wall Thickness allows to measure the wall thickness at a selected surface point.  

Pressing LMB only selects the closest surface point below the cursor for 
dimensioning. Pressing ALT + LMB causes the closest triangle corner point to be 
selected instead of the surface point below the crosshair icon. This will enable 
selecting accurate triangle corner points for the measurements: 

 

Now you are ready to edit and move the annotations (or measurements).  

− Click with the right mouse on top of an annotation. 

You should see the Annotations popup menu below. If you see the Display area 
RMB popup menu select the Next command in the popup menu until you get menu 
associated with the annotation: 
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This menu allows you to Edit, Move and Delete existing annotations. Try these 
commands on the selected annotation. The Edit operation only allows you to 
change the text contents: to re-measure the target points, you must make a new 
measurement (and possibly delete the original annotation). The Move operation 
similarly only moves the text box, not any of the measured points. 
You can also add free annotation texts and messages with Dimension > Mark-up 

command ( ). 
You can display model information on the screen by simply giving the command 

Dimensions > Object Info ( ).  
To copy the object info into the cut buffer, give command Dimensions > Copy 

Object info ( ). From the cut buffer it is easy to paste the information to Microsoft 
Excel, for example. 

Dimensioning can be made Sticky through the Preferences tab (see Edit > 
Preferences > General Tab), you can then give as many consecutive Point Value, 
Point Distance etc. commands as needed without the need to repeatedly restart 
the command. In the Sticky mode you should press ESC or RMB to quit when you 
are ready. You may try it now but remember to turn Off the Sticky mode before 
continuing.   

You can now delete all annotations by pressing the  icon. 

 

Repairing the slubox model 

Now it is time to repair the gap in the slubox-gap model. 

Make sure the shell “1. slubox-gap (Verified)” is selected in the Model Tree. Then 

− give the Fix Model > Repair Shells command and 

you will see the following parameter dialog:  
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− Just press OK when the parameter dialog appears, and you will have a 
correct slubox model in a second: 

 

 - Press OK to close the Status message dialog.  

This was the first lesson covering viewing, dimensioning, popup menus, object 
selection and other basic software usability issues. In the sequel we will show the 
use of the actual repair and 3D model manipulation commands.  

 

 

Lesson 2 – Fully Automatic STL fixing  

This lesson shows you how to fix an erroneous STL model for 3D Printing or 
simulation software use using the automatic tools with 3Data Expert software. 

Clean up the software workspace before continuing by  

− giving the File > New command. Do not save the result of the previous 
example. 

 

Auto Repair process for STL files 

When inputting a triangulated model into 3Data Expert an automatic analysis and 
repair process is started. In normal everyday use you can correct most of the 
models using the Auto Repair process.  

− First open the dino-connected.stl file in the Tutorials / GeomFiles 
directory. 

 You will be prompted for the units, accept the proposed unit, millimeters (mm): 
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 - Press OK to continue and  

you will be prompted for the Operation Mode. To start fixing press the Fix button 
in the Operation Mode dialog now. 

3Data Expert will begin automatic model verification (the Fix Model > Verify Shells 
command). The screen is erased, and a progress bar appears. When the analysis 
is ready, the Auto Repair dialog with Model status message is displayed: 

 

The message indicates that there is one verified shell, which also contains errors. 
The display shows red Gap curves through the surfaces. Gaps are an error type 
you must fix during the repair process.  

− Press the Yes button to initiate Auto Repair. The parameters are 
automatically set correctly.  

Auto Repair will attempt to fix all shells with errors. When you only have one shell 
in the Model Tree you should always try Auto Repair first.  

When Auto Repair is started the shell is run through the automatic repair command 
(Fix Model > Repair Shells command) using automatically calculated parameters. 
For each shell, a progress bar shows the progress of the repair. After the Auto 
Repair process finishes the following message is displayed for the dino-connected 
model:  
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− Press the Close button in the upper right corner to close the window. Also 
close the possibly appearing tips and platform fit warning message.  

The model is now ready for output and 3D printing.  

 

During Auto Repair, 3Data Expert attempts to fill all gaps and remove non-manifold 
triangles (overlapping triangles, multi-edge triangles, duplicate triangles, triangles 
having less than three neighbors, etc.) from the model. Also, duplicate and 
overlapping surfaces are identified and optimally joined. To see more about 
triangle errors, please access the “Triangle errors” page in the Online Help chapter 
“Handling Faceted Files”. 

With certain models, you may see a different result icon for a shell in the Model 
Tree:  . This means that some errors have been found in the model, but they do 
not negatively affect the 3D Printing. The Help text below the Tools Window shows 
what errors remain in the model. What is considered a significant error, depends 
on the properties of the 3D Printing process. You can also change yourself the 
settings of what is an error and what is a warning, through Fix Model > Define 
Warnings: 

    

 

The dino-connected.stl model only has simple errors, like inverted triangles and 
gaps, which are all fully repaired during the Auto Repair process. You can now 
continue to save and print the model, as indicated by the status information in the 
Fix tab Help text window.  
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Lesson 3 – STL fixing  

This lesson shows you how to fix slightly more erroneous STL model for 3D 
Printing or simulation software by using the automatic tools with 3Data Expert.  

Verifying and repairing the STL model 

Start this lesson by  

− File > New command to clean up the workspace. Do not save the result 
of previous example.  

− File > Open the STL model Tutorials > GeomFiles > dino-
separate.stl. 

The software will prompt you for the Units and Operation mode as usual.  

− Accept millimeters (mm) units and 

− start the Fix mode. After a while the software displays the Auto Repair 
dialog with Model status message:  

 

 

This is the result of the automatic analysis (a separate verification of the input 
model with Fix Model > Verify Shells would yield the same result). We can see that 
the 9 shells in the Model Tree are all separated by thin gaps. 

The automatic verification and fixing functions in 3Data Expert have now analyzed 
the model and propose the following repair actions:  
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• Normal repair to stitch separate shells into one shell. This is done when 
more than 70% of the open edges between the different shells can be joined 

• Fill gaps in all shells is proposed as the model contains open/flat shells in 
the result which may require Offset or Extrude for proper fixing into a solid 
shell.  

• Remove tiny shells, less than 0.01 % of the total size, is proposed. This will 
ignore all insignificant shells smaller than the given size in the result. Minor 
shells can be the result of needle triangles and other minor errors in the 
model.  

We will now repair the model with complex gap errors into one single shell with the 
Auto Repair process.  

− Press Yes to run the automatic repair on the model 

After a while we will have a fully repaired model in the Model Tree, ready for 3D 
Printing.  

 

 

Close the dialog by pressing the Close button in the upper right corner of the 
message dialog. 

 

Verifying and repairing, take two 

In very old versions of DeskArtes 3Data Expert (10.0 and earlier) it was necessary 
to run the automatic repair for this model through Fix Model > Repair Shells 
command. In the following, the old way to fix dino-separate.stl file is repeated learn 
some basic concepts of model errors.  

Restart the lesson by 

− File > New command 

− File > Open the dino-separate.stl 

− Accept millimeters 

− start Auto Repair by pressing Fix in the Operation Mode window 
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You will again see the Auto Repair dialog with the status message. 

− press No to quit Auto Repair process 

 

 

A status dialog appears:  

 

− When the status dialog is displayed, press OK to close it. Close the Tip 
and does-not-fit-into-platform windows as well. 

The dino-separate.stl part is split into nine shells (components) which together will 
make the full part.  

 

Using Repair Shells command 

Thin gaps between the surfaces in a triangulation is normally caused by an 
erroneous surface triangulation for 3D Printing; The surfaces are triangulated 
separately without connecting the faces at the trim curves (or surface edges). 
Larger gaps may be due to missing surfaces in the original model. With DeskArtes 
3Data Expert you can easily repair these STL model errors: 
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In the Model Tree, after the Fix Model > Verify Shells command, the dino-separate 
model components are sorted according to surface area. This helps us to first 
delete unnecessary minor components from the model, by just checking the last 
small components in the Model Tree.  

− Select the last component 9. dino-separate (Verified) and Fit it on 
the screen: 

 

We can immediately see that this is an important component and must not be 
deleted. The components before the 9th are even bigger and must thus remain in 
the model. So, in this case we won’t immediately delete anything. 

The next step is to combine the separate dino components into one connected 
part.  

− Use multiselection on the Model Tree to select all components (or 
select Model Tree root): 

 

 

− Then start the Fix Model > Repair Shells command to stitch the 
components into one part and to fill in the missing soles of the dino. 

The command can be started from the Fix Model Tab shortcut button, too: 

 

Use the default parameters:  
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There are several parameters for the Repair Shells command. The parameters are 
automatically calculated for each model and can normally be accepted as is: 

• Normal vs. Simple repair: Normal will stitch separate shells into one shell, if 
possible. Simple repair repairs each shell separately and does not connect 
them into one.  

• Fill gaps in all shells vs. No fill for flat/open shells: 

◦ Fill gaps in all shells fills all gaps in all shells, regardless of the shell 
shape, according to the Fill large gaps parameters.  

◦ No fill for flat/open shells leaves flat shells unfilled. These shells may be 
more suitable to be filled with Offset or Extrude surface commands.  

• Check for triangle errors: to report intersections, multi-edge and overlap 
conditions 

• Consistency recheck: to check duplicate and overlapping surfaces and use 
optimal connection algorithms between these surfaces to form a solid shell.  

• Stitch gaps thinner than: to connect separate components where the 
distance between open edges is less than given value 

• Fill large gaps: to close all gaps smaller than given value. Value All is 
applied to close all soles of the dino. For textured and colored models you 
may want to apply Use surrounding texture and Use surrounding triangle 
vertex colors to keep the original colors in the result, otherwise the default 
foreground color is used for fill triangles (the foreground color is set in the 
Color operating mode tab).   

• Remove tiny shells: shells whose area/volume is less than 0.01 % of the 
total area/volume are removed.  
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− Check that parameters are as in the image above and then press OK 
to start the Repair Shells command 

 

After a while the Repair Shells operation will finish and the status is displayed:  

 

The software reports a fully fixed model which can be printed with a 3D Printer. A 
close-up at the leg/body connection shows how the triangles are stitched at the 
gap area (displayed in shaded+wireframe mode): 

 

 

We have now fixed two models with relatively simple errors. For more information 
on how to fix more difficult STL and VRML models, please see the 3Data Expert 
14.1: STL and VRML repair examples document. The document covers the fixing 
of several difficult models for 3D printing and Additive Manufacturing.  

 

 



3Data Expert 14.1: Tutorial 1 - Working with 3D Models  

 Page 33 

 

Lesson 4 - Splitting and Combining STL 

This lesson shows you how to split large STL models for 3D printing and Additive 
Manufacturing. Building a very tall part may be more expensive than building two 
or more lower parts simultaneously. Also, the building area may not be large 
enough for a very big part. Correct joining of the split parts is ensured by adding 
guiding pins to the models.  

This lesson is not applicable to 3Data Expert Free.  

Splitting the dino model 

− Start by inputting the DeskArtes geometry file DinoOk.3de In the 
Tutorials / GeomFiles directory. 

− Set the file type to .3de to input DeskArtes proprietary files: 

 

The DinoOK.3de file includes a correct triangulation for the familiar dino model.  

You should accept the proposed units and go directly to the Modify mode by 
pressing the 

 

button in the Operation Mode Window. You should see the following dino model:  
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with the Modify Tab on the right-hand side of the screen. 

 

The Modify Tab gives shortcuts to the 
commands most used for adding or 
changing geometry before the final print 
preparation, like split, connect, add lap 
joint, hollow, offset, drain hole, 3D text. 
The Help text provides context sensitive 
help to the commands. 

 

 

− Select node 1. DinoOk (Repaired) by clicking it with the left mouse in 
the Model Tree. 

Before splitting we must take a correct view to the model because the splitting 
plane is generated by extruding a user drawn split polygon away from the viewer. 
With 3D Printing the correct way normally is to split the model perpendicular to the 
z-axis to make the part lower. Thus,  

− take a view from the x-axis direction with View > Ortho View > Front 

(+X) (  + LMB). 
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The splitting is  

− started now with command Modify Faceted > Split or with icon 

 

The system prompts you to take the correct view (in case you haven’t set  it yet):  

 

When the view is correct you can  

− press Continue or Cancel to quit. You may hide this window 
permanently when not needed anymore. 

The system asks you if you wish to use a Polyline (linear), Curved split line or exact 
Coordinate value.  

− Select Polyline 

 

− press OK and the system goes into the curve edit mode where you can 
define the shape of the splitting surface. 

 

Now you can draw the shape for the splitting surface.  

− Draw a horizontal line by giving two points with the LMB clearly 
outside of the dino model 

as seen here (the line is exactly horizontal when a dashed help line extends as a 
continuation of the line):  
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The curve editing is finished by  

− pressing the RMB (or ESC key to cancel if you need to redraw) 

When finished the model is split along the plane defined with the user drawn 
polyline, Select the second shell in the Model Tree to highlight the top half: 

 

 

The two halves are grouped and named with a- and b- prefixes to distinguish 
between the shells above the split line and below the split line.  

Note: If you are splitting models with more than one shell you can select the a or b part with 
the Groups command in the Model Tree popup menu.  

 

Creating the pins 

The separate parts of the model could now be stored into .stl files for 3D Printing. 
However, precise joining of the ready parts would be difficult or impossible. To be 
able to position the parts accurately after the build, we shall add pins and holes in 
the shells to connect them together when they come ready from 3D Printing. 

We will first select and show the locations of the primitives required for connecting 
the two parts together. For that we will get a nice view for pointing the pins on the 
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screen. Here we are also using the shaded+wireframe view mode through the   
icon in the Viewing Toolbar.  

− Rotate the model to position shown in the image below 

− erase the screen with  and 

− select the lower part of the dino and Fit it  on the screen, so that 
it is displayed properly on the screen 

− set on shaded+wireframe mode with the    icon 

Zoom close to the model to be able to accurately position the pins: 

 

The pins are now  

− added with the Modify Faceted > Connect command or 

using the Modify Tab shortcut 

 

After the command is given, it is possible to give the shape and the size for the 
pins to be created. Set Diameter and Length both to 10.0, as seen below:  
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The positions for the pins should look like the this:  

 

If a pin is incorrectly located on the shell, you can remove it by clicking the red 
indicator cone again with the LMB. Then reposition the pin again with an LMB click. 

When ready  

− press OK to generate the connectors. 

After a while you will see the connectors added to the selected shell (in shaded 

mode again with the  icon in the Viewing Toolbar):  

 

Corresponding holes are automatically created into the b-dino-Ok shell. You 
should move the shells apart from each other with the Transform menu commands 
prior to outputting the model for 3D Printing.  

For a robust Boolean operation between the selected surface and the pins, the 
connector is positioned on the surface so that 10% of the height is below the 
pointed surface. 90% of the pin length is above the surface and will be cut into the 
opposite part.  
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Saving the result 

You can save both files into the same STL file by selecting the Model Tree root All. 
Anyhow, you normally want to build and position the parts separately in the 3D 
Printer. For that select each shell separately and  

− output it to a proper STL file with File > Save As command. 

If you wish to save the two parts into one file, you should move the shells apart 
from each other with the Transform or Print Preparation > Move Platform menu 
commands prior to outputting the model for 3D Printing. To output one file, select 
the Model Tree root All before the Save As command.  
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Using Lap Joint to connect thin parts 

With this example we will split a part with thin walls and connect it with a lap joint 
connection. A lap joint is a small overlapping structure on both sides of the wall 
along the split surface edge. With Lap Joint command you can generate strong 
bond even along very thin walls.  

We will first input the familiar slubox-gap.stl file and repair it for Splitting: 

1. Input file slubox-gap.stl file with File > Open. 

2. Accept millimeters as the unit. 

3. Choose Fix in Operation Mode to go to the Auto Repair process. 

4. When asked “Do you want to run Auto Repair” press Yes. 

5. And after a while you will get “Congratulations, the model is correct 
and can be saved and printed” message.  

6. Press Close button in the upper right corner to close the status 
message window. Also close other possibly appearing messages. 

You now should have the slubox model fully repaired for splitting: 

 

− Take a suitable view direction +Y for splitting by pressing the  icon:  
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Start model splitting with  

− Modify Faceted > Split command now and 

− select Split curve type Curved line, as seen in the next page.  

This time we want to make a split line which is not straight, i.e. it has teeth, and the 
split line corners are slightly rounded. This will allow us to create a connection with 
no freedom of movement between the split parts as well as to avoid small holes 
between the connected halves due to too sharp corners in the split plane.  

 

− Press OK to start adding curve points. 

For each split curve point at the curve corners below  

− press twice for each point with the left mouse (points inside the red 
ellipse below). 

This will generate a rounding with small radius at each corner (single click would 
generate a “wavy” split line): 

 

Or if even a bigger radius is needed at each corner, create two points close to each 
other, not double points3. This will increase the radius at each corner and allow to 
use bigger Lap Joint Height values later, for example.  

When ready drawing the split line,  

− press RMB to split the model: 

 
3 The curve is actually a Bézier curve. 
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If you now display the selected half of the model and zoom closer to the tooth, you 
can see that there is a small rounding to enable more accurate building of the part 
without cracks at the sharp corners: 

 

 

Adding Lap Joint 

You are now ready to start generating the Lap Joint.  

− Give the Modify Faceted > Lap Joint command. 

You can also start it by pressing the Lap Joint icon in the Tools Window Modify 
tab:  

 

Let's now fill in the parameters for the Lap Joint command. It is important to use 
parameters suitable for the split part. The Lap Joint Depth (2 mm) must not be too 
deep when compared to the wall thickness (about half) and Height (2 mm) should 
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be suitable to create a strong bond between the two halves after the build. There 
are also three different Lap Joint Types available, this time we will  

− use Thin wall type to create the lap joint structure just on one side of 
the part. 

− Fill in the parameters seen below:  

 

The Allowance 0.1 mm will leave a small void between the lap joint halves for the 
parts to fit easily and to allow for adding adhesive between the lap joint halves.  

You are now ready to select the Lap Joint locations. Locations must be selected 
along the split surface edge. When a lap joint location is selected, a red indicator 
box appears on the edge (see picture below) and the lap joint area is shown with 
yellow indicator boxes. The yellow indicator boxes allow you to check that the lap 
joint is correctly located as well as that the Depth and Height are reasonable. Also, 
if the yellow boxes intersect each other, the generated lap join may not be valid. 
To redefine a lap joint, click the red indicator box and the lap joint disappears. 
Modify the parameters or press another point to change the location, if necessary.  

You can use mouse wheel zoom and middle mouse rotation during the Lap Joint 
command to visually check the lap joint area.  

As in the picture below  

− select two locations indicated with red boxes. 

The yellow boxes show the size and location of the corresponding lap joint 
structures: 

 



3Data Expert 14.1: Tutorial 1 - Working with 3D Models  

 Page 44 

 

 

When ready defining the lap joints,  

− press OK to create them. 

The lap joint structure is automatically deleted from the displayed part and added 
to the other split halve (thus you must not move the split parts before adding lap 
joints between them).  

Note also, that the lap joint positions (red boxes) are selected at the edges of well 
behaving triangles (not thin), this will ensure the best possible result with the lap 
joint generation.  

After pressing OK, the software checks if more than one lap joints should be 
generated.  

− Press Yes to generate both areas. 

 

 

After a while you will see the result, a lap joint structure deleted from the other part 
and added to the other halve: 
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The parts can now be outputted and built separately and then accurately joined 
and glued back together.  
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Lesson 5 – Positioning Parts 

This lesson shows you how to use the 3Data Expert commands to position parts 
before transferring to Additive Manufacturing machines. The Platform definition 
and Move to Platform commands are accessed through the Print Preparation 
menu.  

This lesson is not applicable to 3Data Expert Free, where part positioning must be 
done manually.  

Note: Most 3D Printing systems will reposition the part when inputted into the 3D Printer control 
software.  

Print Configuration 

When you start 3Data Expert, you will see a workspace4: 

 

When 3Data Expert is started the first time, a default Print Configuration 
(GenericDLP) is loaded, along with an associated workspace. We will now show 
how to load another configuration set saved during the 3Data Expert installation. 
Note: this lesson is only meant to be a guideline, you may have a suitable Print 
configuration pre-installed and loaded. 

First, let’s make the Tools Window visible via User Interface > Tools Window (or 
Shift + F8).  

 

 

4 If the workspace is not shown, click the  button to make it visible 
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Then choose the Print tab. The Print Configuration file 
interface is displayed as its first group. 

Below the Print configuration group, the most often used 
parameters (which are often modified during print 
preparation) are shown. 

From the File drop-down list, you can choose a 
configuration from the preset configurations (or a 
previously used one): 

 

Click the  button now to get a closer look at how to 
choose and tune different Print Configurations. 

 

The Generic DLP parameters are shown in the Print 
Configuration and shown in the dialog. You will see 
the Print Configuration Setup interface (picture on 
the right). On top, there is the Print configuration 
settings file management area. Below it, you can 
see the parameter categories and category-specific 
parameter values. 

From the settings file management area, you can: 

• Load settings from a parameter file (for 
example, to open a Print Configuration tuned 
to better match your 3D printing 
requirements). 

• Save current settings into a parameter file. 

• Change the order in which Print 
Configurations appear in the drop-down 
menu (useful if you have many of them). 

• Select where to browse the parameter files, 
either system or personal folders 

• Import and export support parameter files (a 
subset of the setup) for use outside the Print 
Configuration context. 

 

The parameters themselves are divided into several categories. For simplicity, let’s 
only look at the workspace size. Click the “Workspace” category. The type and 
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size of the workspace are displayed, as well as additional parameters required for 
a specific printer. Change the workspace box dimensions: Xmax to 200.0 and Zmax 
to 300.0: 

 

Then click OK to close the Print configuration parameter edit window and start 
using the new parameter set.   

Let’s now try to exit from 3Data Expert. A warning is shown that the print 
configuration has been changed. Click No in the message window, because we 
want to save our modified Generic DLP parameter set for later use. 

 

Now, re-open the Print configuration setup window with the  button, click 
Save to select where and with which name to save the parameter set: 
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In the file dialog, go to the folder where you want to save the print configuration 
setup, type the new parameter file name, and finally click Save. 

Now you can quit 3Data Expert. The next time you start it, the print configuration 
parameters last used are automatically loaded: 

  

 

Moving parts into the platform 

Now we will see how the Print Preparation > Move to platform commands are used 
for positioning the part into the workspace. The move platform commands will now 
use the minimum/maximum x,y,z values of this platform when computing the 
default values for the movement. 

Let's first  

− input the model Tutorials/GeomFiles / rava2.stl using the File > 
Open command 

− simply close the Operation Mode window by pressing its close 
button.  
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We can see that the part is not fully inside the build area, both visually and from 
the model properties window at bottom left (platform size, bounding box, extents).  

− Select part rava2 from the Model Tree, then 

− move the part into the area with the command Print Preparation > 
Move to Platform > Move positive.  

The command suggests the default values which are the same as the minimum 
bounding box values for the workspace.  

− Fill in the values below and press OK. 

 

 
This means that the minimum corner point of the part bounding box is set to the 

given values. You can check this by turning the grid on  and taking a view from 
the +X direction:  

 

 

Then give command Print Preparation > Move to Platform > Move center (or 

click the  button in the Position tab). 

Move Center computes the center point of the selected platform and uses this as 
the default for x and y values. The xy center point of the object is moved to this 
point. You still must give the z distance from the bottom of the vat (to allow for 
supports, for example).  

− Fill in the level value below and press OK. 
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You should get the result as view here from X axis (left) and Z axis (right). Note 
that the model barely fits into the workspace and would require either splitting or 
scaling: 

 

 

The Move to Platform > Move Level command only moves the part in z-axis 
direction to add sufficient space for supports.  

You may want to try the normal transformation commands also. They are 
accessible from either the Transform menu, the Transform toolbar or the Position 
tab: 
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The toolbar includes commands for part moving, scaling, rotation, and mirroring. 
The Transform menu gives you more commands, like numeric transformations, 
scale from MM to Inch and the other way around. The Position tab contains the 
most used transformation commands and additional tools from other menus: 
Duplicate object, Merge shells, and Copy to array, Move to platform center, Move 
to platform level. 

 

Lesson 6 – Nesting 

This lesson shows you how to use the 3Data Expert commands to position parts 
automatically using 3D Nesting.  This is done with Print Preparation > Nesting 
Tools > Nesting command. Currently 3D Nesting is available for efficient part 
merging for powder-based system which do not require supports during the 
manufacturing.  

This lesson is only applicable with the Base and Lite modules   . 

 

3D Nesting regular components 

In this example we will pack a set of consistently ordered similar components into 
the work area, aka bin with nesting. The goal is to organize 73 scaled rava2 parts 
into the bin as effectively as possible.  

In the images below we have 73 original components show in the left-hand image 
and nested 73 components in the right-hand image: 

  

 

Before nesting we need to generate the 73 components to nest: 

- Input rava2.stl and run Fix Model process on it 

- Use Transform > Scale > Numeric to scale it to 20% of the original size 
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- Create an array of objects with Edit > Copy to Array command or, in the 

Position tab, click the  button 

 

- Click OK. After a while you will see an array of 72 components added to the 
Model Tree 

 

The 72 new copies are in a single shell. For Nesting we must separate each copy 
into its own shell. 

- Select the “2. Rava2 (Copy Array)” shell and run Fix Model > Verify 
Shells command on all components to separate the copies 
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- After a while you will have the original and 72 separate new shells in the 
Model Tree 

 

 

We are now ready to start nesting the parts. You may want to read the Help pages 
for the Nesting command to generally learn about the different parameters 
available for the Nesting command. In the sequel we will make some specific 
changes to the default parameter set to get the best possible nesting result for the 
rava2 array.  

We will start the nesting by 

- Select the Model Tree root All 

- Give the Print Preparation > Nesting Tools > Nesting command and you 
will see the Nesting parameters dialog.  

Fill in the parameters below, if not already set. Especially note the Orient algorithm 
= orig-dir and Init algorigihm = bin split. The component directions will not be 
changed during the nesting and the bin initialization is done by splitting the bin into 
boxes which fit each component. A one-minute run time is sufficient because most 
of the nesting is performed by the initialization algorithm (bin split).  
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- Press OK to start the nesting 

- About one minute later you will have the result in the Model Tree: 

 

Generally, it is useful to position the components so that the longest edge is along 
the longest edge of the bin. If the Orient algorithm is set to z-rot or xyz-rot, the 
software will try to find the longest component edge and align it to the longest bin 
edge before the initial bin fill.  

3D Nesting irregular components 

When the components are more irregular and/or different sizes, different 
initialization and orientation algorithms can be used to achieve better results than 
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simple z-rot/bin split algorithms would give. We will give a couple of examples here 
and also show how the allowed nesting time affects the results.  

We will first prepare a set of dino components to nest: 

- Input dino-separate.stl and run it through the Fix Model process 

- Change the workspace size to 250 * 250 * 250 cube (Print Preparation 
> Print Configuration > Workspace) 

- Scale the model to 50% of its original size 

- Create Array of 49 components 

 

- Run Verify Shells to separate the Copy Array result to shells 

Now you should have a set of 50 dino shells in the Model Tree. For easier 
comparison during later steps, take a view from the X axis, fit the workspace into 
the view, with some extra space above:  

 

Next, we will run the shells through the same parameters as was done with the 
rava2 example above. We will use a bit longer run time, 1 min 30 sek. 

- Select Model Tree root All 

- Give command Nesting with the following parameters (orig-dir, bin-split):  
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- Press OK to start nesting 

- After a while the result is available in the Model Tree: 

  

This time the shells did not quite fit into the workspace. Anyhow, with more dense 
merging the shells should fit there.  

Let’s try improving this nesting with the z-rot and rain-fall methods: 

- Start the Nesting command again with the following changed parameters: 
Orient alogrithm = z-rot and Init algorithm = rain fall. 



3Data Expert 14.1: Tutorial 1 - Working with 3D Models  

 Page 58 

 

- Answer Yes to the question asked after the OK is pressed. This will 
continue with the existing nesting and improve it using the nesting algorithm: 

 

This time the nesting should be lower or even fit into the bin. In the image below is 
one example of the new nesting result:  

 

After a couple of improvement runs, we will get a more compact nesting:  
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You can still try another Orient algorithm, xyz-rot (marked with red line below), 
where the shells can be rotated freely during the nesting.  

 

The result will be similar in height than the previous exaple, and can be improved 
by rerunning the command on the result.  

 

After a couple of iterations, some of them using z-rot, some xyz-rotz, we may 
achieve a result like this: 

 

 

Above we were using 1 min 30 sec run time. With some model compositions using 
a longer run time, like 30 minutes, yields the best result. However, a better packing 
can be often be achieved using shorter run times and alternating between z-rot 
and xyz-rot parameter settings. 
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Lesson 7 – Adding 3D Text 

 

Sometimes it is necessary to add decorative texts or tag parts with individual texts 
to tell them apart after the build. The 3D Text and Boolean commands make 
marking parts easy and effective.  

This lesson applies to Base, Lite and Color modules only.  

Creating 3D Text 

Normally you want to add the 3D text on a part to be built. To start the lesson, first 
input and repair slubox-gap.stl: we will first input the STL file and repair it for adding 
text: 

1. Input file slubox-gap.stl file with File > Open. 

2. Accept millimeters as units. 

3. Press Fix Model with Operations Toolbar to go to the Auto Repair 
process. 

4. When asked “Do you want to run Auto Repair” press Yes. 

5. And after a while you will get “Congratulations, the model is correct 
and can be saved and printed” message.  

6. Press Close button to close the status message, as well as all other 
similar message windows.  

You should now have the slubox model fully repaired for adding 3D text. Take a  

− view from Y axis direction and 

− give the command Create Geometry > Create 3D Text:  
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Fill in the values given in the dialog above: Size 12 mm (vertical height), Height 1.2 
mm (=text height from the surface) and finally String “slubox repaired”. The font is 
preset to Arial, well use that. Show position on surface is set. When we  

− select Surface operation Engraving. 

− make sure Show position on surface is set. 

− press OK the program asks us to show a line on the surface along which 
the text will be generated. 

− You can now position the text with LMB on the correct location. 

When positioning the text just make sure the whole text fits on the flat surface area 
on slubox:  

 

If necessary, you can scale and rotate the text on the graphics area to better fit it 
on the slubox model. The yellow Help text window on top of the graphics area 
shows the different text positioning options available: 

 

When positioning is done, click RMB to start text engraving. 

Soon you will see the text engraved on the slubox surface (turn wireframe off and 
rotate the view to better see the text): 
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Generally, 3D Text can be attached on both flat and curved surfaces. If the surface 
is curved, you should use the Curved surface option to reliably attach the text on 
the surface. If not used and the surface is too curved along the given text path, 
some letters may not be attached to the part or may be fully inside the part.  

 

Adding 3D Text to multiple parts 

Sometimes it is necessary to add text and label strings to multiple objects at once. 
For example, quality checking may require that every object on the printing 
platform can be uniquely identified.  

An indexed Label string can be added to the shell onto which the 3D text is added 
(engraved or embossed); this will help component identification, together with the 
Production Screenshot image or the Generate Report documentation.  

Note: The parts which will be added with the same text must be rather similar. The 
text position is defined in relation to the bounding box middle point of each 
component. If the shape of the components is very different, the text in each shell 
may end up in wrong locations.  

For this example, we are using the 12-cellphones.3de file in the GeomFiles 
directory.  

- Input the 12-cellphones.3de file (closing the Operation Mode dialog with 
the upper right corner X) 

 

- Take a view from the Z direction 

- Zoom into one of the copeis to define it as a reference shell: 

 



3Data Expert 14.1: Tutorial 1 - Working with 3D Models  

 Page 63 

The goal is to add an identifying string to each of the components for identification 
after the build. This is achieved with the 3D Text dialog fields Set Production 
Screenshot Label string, Apply text to all multi-selected objects and Add indexing 
to the string. 

- Keep Model Tree root All selected 

- Give the command Create Geometry > Create 3D Text 

- The Text Input dialog appears. Make sure all the values are as seen in the 
image next page: Letter size, Height, Show Position…, Set Production …, 
Engraving, Add index…, Apply text to… etc. The shell is rather thin, so 
especially the Height/depth must be very small.  

 

- Press OK to start positioning the text on the reference shell currently in view 

- Position the text on top of the reference shell. Move the text with LMB, 
rotate with Ctrl+LMB, resize with Shift+LMB: 
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When the text is at the correct location on reference to the upper left shell,  

- Press RMB to add the text to all selected shells 

- After a while the result is visible at the Model Tree, each component has the 
text with increasing index added: 

 

 

The Text is added starting from the last selected shell in the Model Tree before the 
command was given and continues towards the shells higher in the Model Tree. 
Before the command the highlighted shell was the last in the Model Tree and will 
get the text “cmp00”: 

 

 

After the command the last shell is the first in the Model Tree with the “cmp00” text: 
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The Label string can be seen in the properties area below the Model Tree or with 
the Object Properties command:  

 

 

- Save the resulting model as  12-cellphones-3D-text.3de for the later 
lesson on Production Screenshot command.  

 

Adding 3D Text on curved surfaces 

3D text can be added on curved surfaces too. However, you need to take care with 
the parameters to ensure that the 3D text is visible on all desired locations.  

Let’s create a primitive cylinder with 20 mm height and 10 mm radius for this 
lesson.  

- File > Close the current model to get an empty model 

- Create a cylinder with Create Geometry > Cylinder command 
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- Press OK to save the cylinder; you should automatically get a clean cylinder 
without the need to repair it: 

 

 

We will now add simple text on top of the curved cylinder vertical side.  

- Start the Create 3D Text command and fill in the following parameters, 
especially note the 400% Tool depth. This will use up to 8 mm (4*2mm) high 
letter primitives to cut the text on the curved surface. Feel free to use the 
font and text of your preference.  
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- Press OK to show the location on the model 

 

- Scale the text (Shift+LMB) to fit on the surface as shown in the above 
picture. 

- You can see a quick glimpse of the temporary engraving tool surfaces (used 
for the Boolean operation) before the actual result appears:  

 

- And finally, the correct engraving: 

 

The text is correctly cut against the model. Let’s try the operation with a smaller 
engraving tool height.  

- Undo the last command 

- Give Create 3D Text with 100% tool height (try an even smaller percentage 
if the result is still correct after the Boolean operation) 
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- Press OK to add the text 

- The end result is a model where the text is not properly attached to the 
cylider model, as can be seen in here (left: shaded, middle: wireframe 
zoomed, right: wireframe looked from almost Z axis):  

 

So, it is important to use a big enough tool height with highly curved surfaces. Also, 
to get the most accurate text projection on the surface, the viewing should be as 
directly towards the average normal of the text insert surface, or anomalies may 
appear.  

 

Lesson 8 – Generating AM reporting 

This lesson shows you how generate different reports for AM production and 
quality control.  

 

Production Screenshot command 

The Manufacturing menu in 3Data Expert 14.1 is intended to contain commands 
which are closer to the ready built AM part. Currently it includes commands to 
produce documentation for post-processing operations and quality control.  

The Production Screenshot command is meant for generating documentation to 
help identifying the parts on the platform after the build. First the user sets up the 
suitable part positioning and orientation on the build area for the parts and 
supports. When ready to go for slicing it is time to produce the Production 
Screenshot. Here we are using as an example the result from the previous 
example, 12-cellphones-3d-text.3de file.  

- Input the 12-cellphones-3d-text.3de  

- Skip the Auto Repair process (simply close the Operation Mode dialog) 

- Give the command Manufacturing > Production Screenshot.  

 

You will soon see a view from the positive Z axis with additional yellow info boxes 
for each component on the platform.  
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Each info box is connected to the corresponding component with a red line (close 
to the middle of each component). In this case the Label strings created with the 
3D Text command are visible in both the info boxes and as engraved into the 
components. This will make identification of each component very easy after the 
build. The properties (size) of the building platform are also shown on the upper 
left corner of the platform; if the platform is defined but not visible, tick the Include 
building platform check box. 

To minimize info box cluttering you can rearrange them with LMB. The info box 
target points can be re-positioned similarly. 

The Export as image button allows saving the image (as a 
PNG file) with a desired name on the hard disk. The 
exported .png file can be inputted or copy/pasted to 
different Microsoft Office documents (for example) for part 
identification and commenting after the build. 

Clicking OK will store the screenshot into the model for 
later viewing with Manufacturing > Show Production 
Screenshot (when the model is saved in either .3de or 
.3dez format). 

 

Generate Report command 

The Generate Report command in Manufacturing menu will allow automatic 
transfer model and geometry related info into MS Office documents for quality 
control purposes. The transferred data will include model name, volume, surface 
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area, size, dimensions, etc. and can be fully defined by the user. For everyday use, 
the data transfer is based on predefined templates. 

For the prerequisites and a detailed description of report generation, please see 
the application Help page Menus and commands > Manufacturing menu > 
Generate Report. 

 

Generate Report Word output example 

 

 

Generate Report Excel output example 
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Lesson 9 – Preparing for 3D Printing 

There are several issues to consider when sending 3D models to 3D printing. Most 
processes are more effective when printing bulky models hollowed rather than 
solid. Also, being able to drain out excess material from the hollow models gives 
remarkable material savings. Open flat surfaces must be offset to a certain 
minimum thickness and too thin walls require material addition to print properly. 
Some processes require external supports to build correct models.  

3Data Expert offers effective tools for preparing 3D models for optimal print results 
through its Modify Faceted and Print Preparation menus. For this and following 
lessons 3Data Expert software is mostly required.  

This lesson is only applicable with the Base, Lite and Color modules.  

Making Hollow models 

Building large and bulky models may require a long time to print or they consume 
large amounts of material. If these models are made hollow, the processing time, 
as well as the material usage, will be minimized.  

Start this exercise by  

− emptying the 3Data Expert work space with File > New and then 

− input the model Tutorials / GeomFiles / DinoOk.3de. 

− Go directly to the Modify Mode 

 

Enable clipping from negative Y direction to see the inside of the dino: 

 

The dino model is a bulky model suitable for hollowing.  
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− Give the command Modify Faceted > Hollow or use the 

 

shortcut in the Modify tab. When the command is given the following parameter 
dialog appears (change the values to those shown): 

 

The dialog gives the extents of the selected part on the Selected object size and 
units group. The default Minimum wall thickness is calculated based on the 
maximum extent of the selected object (13.67 mm in this case). The default value 
is too large for this model: change the Minimum wall thickness value to   4 mm as 
seen in the image above.  According to the default Advanced settings we will make 
the hollowing surface Inside the Dino model and use the default Accuracy.  

− Fill in the parameters above and 

− Press OK to start the hollowing.  

After a while the Hollowing is ready. To see the actual result, you can use Clipping 
to look inside the model. As seen in the image below, the model is now made 
hollow by adding a new surface inside the original surface.  

 

The hollowing is done by filling the inner void of the model with empty boxes. The 
size of the boxes is defined by the Minimum wall thickness and Accuracy settings 
in the parameter dialog. The inner surface triangles are generated where the 
distance of an empty box wall from the original surface is at least the given 
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Minimum wall thickness. This guarantees that the wall thickness is at least the 
given value.  

The Hollowing command can only be used with solid models. If you wish to make 
an open surface a solid you should use the Modify Faceted > Offset command.  

 

Hollowing with Scan Offset 

The basic hollowing method described above removes a voxel-type volume from 
inside the model. We will next use another hollowing method which produces a 
smoother inside cavity, although with more steps and calculation time: the Scan 
Offset method. 

Let’s again start with the same Dino model. After reading the model, select shell 
DinoOk (Repaired), then start command Modify Faceted > Scan Offset. A 
parameter dialog appears. In the dialog, set Wall thickness to 5.0 and Offset 
accuracy to 1.0, Offset direction to “Back”, uncheck all the checkboxes, and then 
click OK. 

 

After a while, the scan offset result appears. It contains errors which need fixing: 
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We will first run the Fix Model > Repair Shells command on the DinoOk (Solid) 
shell, with the following parameters (in particular, Remove tiny shells should be 
checked): 

 

After the repair, statistics will be shown (click OK), then the Remove Tiny Results 
dialog (use the values suggested and click OK): 

  

Even if most undesired small details are removed, some remain and must be 
removed manually. From the Model Tree, select all other shells than the first one 
(the original Dino model), the graphically unselect the biggest Scan Offset result 
part (Ctrl + pick the part; showing bounding boxes clearly shows what has been 
selected): 
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Delete the selected small parts. Now (for clarity) change the model color of the 
internal part to yellow (in Edit > Properties), select All and apply clipping to see that 
there are two shells: 

 

 

To convert the inner shell into a cavity inside the outer shell, select the inner shell, 
give command Edit > Cut, select the first surface of the outer shell and give 
command Edit > Paste: 

   

 

Now the inner shell is topologically correctly defined as a cavity. We can measure 
the wall thickness at a suitable point to see that the thickness is close to 5 mm: 
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Creating a 3D Lattice 

A large cavity is often not a structurally feasible means for saving material. In the 
following we will take the temporary Scan Offset result and convert it into a 3D 
Lattice structure, and finally convert the lattice structure into a cavity inside the 
Dino model. 

First undo the Scan Offset steps until you see two DinoOK (Repaired) shells, 
then select the innermost one and hide the original Dino: 

 

Then start command Modify Faceted > 3D Lattice. The parameter dialog for 3D 
lattice generation is shown. For a concise description of the parameters, please 
look at the 3Data Expert Online Help (F1). As seen in the picture below, set the 
following parameters: 

- Lattice geometry type: Voxel 
- Lattice geometry area: Inside selected object 
- Accuracy: 1.0 (using a small value would significantly increase calculation 

time) 
- Turn on parameter Connect lattice and objects 
- Beam smoothness: 8 
- Beam thickness: 5 
- Hole size: 5 
- Rotations along axes: X and Y: 45 degrees, Z: 0 degrees 
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3D Lattice dialog buttons do the following: 

- Show Net: display a quick preview of the lattice structure 
- Create Triangles: calculate a triangle model of the lattice. This is still a 

temporary preview of the final 3D lattice, but allows you to investigate the 
details of the structure 

- OK: Create the lattice triangles and add them into the Model Tree. 

 

 

Let’s first click Show Net to get a quick preview of the lattice generated from these 
parameters: 

 

Next we will click the Create Triangles button. To better see the effect, we hide the 
original shell in the Model Tree and apply clipping from both sides of the X axis: 

 

 

Next click OK to add the lattice into the model tree. The lattice will be automatically 
repaired and tiny details removed (click OK in the Remove Tiny Results dialog). 
Even after this the model needs more cleaning: 
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Remove first any remaining small Lattice (Offset) shells from the Model Tree. To 
fix remaining (big) Lattice (Offset) shell, run (probably several times): 

- Fix Model > Delete Errors (with parameter Also triangles close to error 
triangles set!) 

 
- Fix Model > Repair Shells 

until you get a clean enough lattice shell: 

 

Next, we will smoothen the lattice. Select the Lattice (Repaired) shell and start 
command Modify Faceted > Smooth. Click Yes to the collapsed-surfaces warning 
message, and set Smoothing loops to 5 and Effect to “Stronger” in the 
smoothening dialog: 
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 Here’s a detailed view of the lattice before and after smoothening: 

   

Let’s again change the color of the smoothened lattice to orange. Finally, Edit > 
Cut the Lattice (Smoothed) shell, select the first surface of the original outer shell 
of the Dino model and Edit > Paste. The model now contains an internal lattice 
structure: 

  

 

Making Drain Holes 

Drain holes are needed when building Stereo lithography or powder based hollow 
parts with large, trapped volumes. The Print Preparation > Drain Holes command 
gives an easy way to make holes of desired sizes in the STL models. 

We will continue with the result of the previous example, hollowed Dino model. We 
will keep the same clipping settings to verify how the drain hole will interact with 
the 3D lattice. 

− First take a suitable view of the dino model to see the underside of the 

model by pressing the  icon with the RMB. 

− Rotate the view so that you can see both the dino belly and the internals 

− Take a measurement of the wall thickness at a suitable position 
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− Give the Modify Faceted > Drain Hole command or press the  

button to start the Drain Hole command. 

Depending on how the hollowing was made, you may get a warning that the model 
is perhaps not hollow. Just accept it with Yes: 

 

A parameter dialog appears; the default values are again calculated based on the 
maximum extent of the selected object.  

− Modify the Diameter and Wall Thickness values, as seen in the 
parameter dialog image below (15 diameter and 5.1 mm wall thickness, 
slightly bigger than the measured wall thickness): 

− Choose Round shape 

 

The holes (one or more) are positioned with LMB clicks on the display area on top 
of the dino model. Give the hole location in the middle of the bottom surface. Note 
that you can use the MMB zoom and MMB rotation to change the viewpoint when 
locating the connectors.  
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− Position a drain hole with LMB in the middle of the bottom surface, 
near the wall thickness measurement point, as seen here: 

 

If the hole location is not correct you can remove it by clicking on the red indicator 
box again. Then reposition with another LMB click on the correct location.  

When ready  

− Press OK to start the Drain Hole generation. 

After a while, the Drain Hole is generated parallel to the surface normal at the given 
location:  

 

Drain Holes can be generated on any wall, they are always created orthogonal to 
the surface at each given location.  

 

Making tapered plugs with Hole Tool 

The Special Modify > Hole Tool is meant for generating holes with different shapes 
and depths for various applications. It can also be used to generate a drain hole 
for hollowed parts with a tapered plug. The tapered plug can be printed separately 
and glued to the printed part to close the hole accurately.  

If you cannot see the Special Modify menu, turn on the Advanced Editing mode 

from the  toolbar button or from User Interface > Advanced Editing Mode. 
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We will continue with the hollowed dino created in the previous example. Now take 
a view from the top of the model, apply clipping from +X direction (almost to the 
middle of the model. 

Then measure the wall thickness at a suitable point at the top of dino’s back: 

 

Write down the thickness. Then start the Special Modify > Hole Tool command. 

A Hole Tool dialog is displayed: 

 

The Hole Tool dialog contains many parameters 
for hole generation. Now we want to generate a 
hole which is drilled in the surface normal 
direction. We also want to generate a plug for the 
hole at the same time. The plug will have tapered 
geometry, to prevent it from falling into the part. 
Also, the plug will be scaled slightly smaller than 
the hole, to enable easy gluing of the plug into the 
hole.  

Start the hole generation by  

• select N-sided hole 

• use Surface normal direction for the hole 
direction  

• set Taper angle to 5 degrees 

as seen in the image on the left.  

The hole location is selected graphically with the 
LMB on the model. When the above parameters 
are set, we are ready to  

- press the New hole button to show the location 
and size of the hole.  

A crosshair icon will appear.  

- Click near the wall thickness measurement 
point to set the hole middle point.  
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Then  

− draw a box by dragging with the LMB to estimate the size of the hole 
to generate. 

− When the mouse is released, a parameters dialog appears  

 

Note: Center point does not apply here, it was selected with the mouse. 

Then  

− Select Side length and set the value to 4.0. Also 

− set the Number of vertices to 8 to generate a plug with distinguishable 
corners for easier positioning after the build.  

− Then press OK to generate the plug indicator on the model, as seen in 
the image below (note how it extends far down through the dino): 

 

Hole 1 will be generated into the Hole cutters list. Now we will set the length and 
scaling for the plug.  
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Then  

− Select “hole 1” in the cutters list. 

− For Hole depth select the From surface, depth and set the value to 5.4 
(slightly bigger than the measured wall thickness). 

− Press Apply to really change the hole depth after setting the depth 
value. Note how the hole tool now extends a little outside the dino outer 
and inner surface, but does not interfere with the lattice structure:  

 

− Make sure the Hole operation is set to Delete.  

− set the Create cap, relative size 98% to make the plug slightly smaller 
than the hole: 

 

When ready,  

− press the Create button. 

The created hole cutter is deleted from the original model and in a few moments, 
you will see the plug fitted in the middle of the screen. The dino model has a 
corresponding hole in the middle of the back (shown with clipping and plug color 
changed to green): 

 

 

If you zoom closer to the hole and change the dino body to wireframe mode (with 
graphics area RMB popup menu) you can see that the plug is slightly tapered and 
smaller than the hole. Another closeup with clipping on the right. 
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These two shells can now be printed separately. After the body is drained from 
non-processed material or any internal support structures are removed, the two 
pieces can be glued back together for a nice-looking part.  

 

Adding thickness by Offset 

There are several software products which do not automatically produce solid STL 
data. For example, many architectural software products output open models 
made of open surfaces unless constructed very carefully. These open models must 
be made solid before inputting to 3D Printing.  

3Data Expert Modify Faceted > Offset command is used to generate solid models 
from open surface models. Open shells can be offset to user defined thickness for 
correct build.  

− Initialize your system with File > New  and 

− input the House.3de model from Tutorials / GeomFiles directory. 

− Go directly to the Modify mode and when the repair question appears: 

 

− press No to continue without repair. 
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The House model contains two open shells, the roof and the walls. The open 
surface edges are drawn with red gap curves.  

We will use the Offset command to give thickness to the open surfaces.  

− Select the roof shell and 

− give the Modify Faceted > Offset command or use the  button. 
The program will notify that there are errors in the model after you give 

the command. 

 

− Press Yes to continue the command (the errors will be automatically 
repaired after the offset): 

You will see the Offset STL parameter dialog. As usual, the default offset distance 
is calculated based on the maximum extent of the roof shell.  

 - Change the Wall thickness to 2 mm and make sure the other parameters 
are as shown on the image below.  

Otherwise, we can accept the default values for Advanced parameters. 
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− Press OK to start the command. After a while you will have a correct 
solid roof in the Model Tree: 

 

− Now select the wall shell and 

− repeat the Offset with the 2 mm Wall thickness again. You may see 
the warning  

 

− Press OK to close the dialog and start the offsetting by 

− pressing OK again in the Offset parameter dialog.  

After a while the offset is ready, and you should have two correct shells in the 
Model Tree: 

 

There are some 3D Printing systems which can produce a correct result from these 
two shells directly. Some systems require the two shells to be connected into one 
shell to produce a correct result. In the next example we will join the two shells into 
one shell using the Boolean commands.  

 



3Data Expert 14.1: Tutorial 1 - Working with 3D Models  

 Page 88 

Combining shells using Boolean commands 

The two shells generated in the previous example are correct, but may not print 
properly if, before outputting to 3D Printing, they are not connected into one shell. 
We will use the Boolean commands to generate a single shell from the two shells.  

Let's first check how the two shells intersect each other. If you zoom in closer to 
the part and use the Clipping to look inside the shells (with X/Y/Z clip curves 
checked), you will notice that the shells truly intersect: 

 

Note: If the roof and the walls do not intersect you may have generated the roof offset to Back 
faces direction instead of Front faces or used too small offset thickness. If so, please start the 
lesson again and follow the instructions carefully. 

Reset and close the clipping window before the next command.  

We will use the Boolean command to connect the two shells.  

− Start the Modify Faceted > Boolean command now. 

The Boolean parameter dialog will appear. It allows you to select the shells from 
the Model Tree, as well as define the Boolean operation to perform between the 
selected objects.  

First  

− select the 1. roof shell in the Model Tree and then 

− press the Set shell 1 button.  

 

The roof turns light blue in the graphics are and its name is displayed in the shell 
1 text filed. Then  

− select the 2. walls shell in the Model Tree and 

− press Set shell 2 button.  
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The walls turn yellow and its name is stored in the shell 2 text field. There are 
several different operations available between the selected objects but this time 
we simply want to  

− Join (default) them into one shell. 

Make sure the dialog looks as seen below: 

 

Then  

− press OK to join the two shells into one. 

After a while you will see the two shells connected into one correct shell: 

 

You may also generate the same Boolean result by multi-selecting the two shells 
and by running the Modify Faceted > Multiple Join command on them: 

  

 

Generally, there are some issues which need to be considered when using the 
Boolean command. Especially important is to make sure that the two shells really 
intersect each other. Tangential or overlapping shells may behave improperly 
when sent to the Boolean operation. In these cases, you should slightly move one 
of the shells or scale them a little. The amount of move or scale should be very 
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small (like 0.001 - 0.01 mm for a model this size), to not affect the accuracy of the 
printed model.  

 

Generating advanced cuts with Cut Tool 

Cut Tool is meant for advanced cutting for various applications. For example, it 
can be used to cut specific details inside a 3D model without disturbing the surface 
area in the close vicinity of the cutaway detail. We will now use it to cut a door 
opening to the house model in the previous example.  

First take a view from the x axis direction by pressing the X icon with the LMB.  

 

 

Then give the Special Modify > Cut Tool command to open the Cut Tool dialog: 

 

The Cut Tool dialog will be used to define a 
Cutting surface to cut away the door opening to 
the model. We will start by selecting 

• Create cutter with Draw surfaces 

• Draw cutter with Polyline 

The profile for the cutter surfaces will be 
generated with the curve editing tool already 
used with the Split command.  

 

- press New cutter button to start drawing the 
door profile on the house. 
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Then  

− input the curve points with the LMB and 

− press RMB when ready with the shape below: 

A new cutter surface is generated into the Cutter surfaces list: 

 

The next step is to set the Cutter surface extents so that it will only cut the front 
wall of the house model. For that  

− select the created cutter in the Cutter surfaces list. 

− select the Slider selection and use the slider to resize the cutter 
surface to correct depth, as seen in the image below 

A colored bounding box is used to indicate the cutter surface size while moving the 
slider with the LMB. The yellow bounding box indicates the maximum size of the 
cutter surface, red bounding box indicates the current size of the cutter surface 
and moving blue lines indicate the new start and end locations to be used when 
the LMB is released.  
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After rescaling the cutter surface to the depth seen above  

− make sure that the Cut operation is set to Separate. 

− Then press Cut button.  

After a while you will see the result on the screen, the cut part (left image below). 
When fitting the house, we see that there is a door opening in the front wall.  

  

The Cut Tool gives you unlimited possibilities to cut models. You can also use 
several cutting surfaces simultaneously to generate even more complicated cuts 
for various applications. For example, in the next picture we can see two cutting 
planes designed to remove a piece from the dino tail, using cutting planes with 
different cutting directions: 

 

Note: When using multiple cutting planes make sure that the surface normal directions are 
consistent for the cut operation: For two adjacent cutting surfaces the normal must either be 
directed towards each other or away from each other. If it is not, the normal direction for a cutter 
surface can be changed with the Swap side button after selecting the surface in the Cutter surfaces 
list.  
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Lesson 10 – Preparing for simulation applications 

This lesson shows you how to use the Reduce and Refine commands in the Modify 
Faceted menu to reduce the number of triangles in an STL model as well as how 
to reshape the triangles for a better aspect ratio. For some simulation software 
systems, it is important not to have too many triangles in the model to speed up 
the simulation. Some simulation applications require triangles with a good aspect 
ratio to produce the most reliable results.  

The 3Data Expert Reduce command can also be used for preprocessing data for 
Augmented Reality (AR), Virtual Reality (VR) and game software systems. If 
required, the reduction will keep the textures and colors on the inputted VRML or 
ZPR model as accurately as possible.  

This lesson is applicable to the Base module only. 

Starting the reduction 

Let's first  

− input the model Tutorials / GeomFiles / rava2.stl using the File > 
Open command. 

Accept the proposed units and when the Operation Mode must be chosen,  

− run the basic Auto Repair process on the model by pressing the Fix 
button in the Operation Mode Window 

− After a while you will have a correct model: 

 

 

Now select the rava2 (Verified) in the Model Tree and  

− give the command Modify Faceted > Reduce. 

The Reduce parameter dialog will appear: 
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There are three different main reduction methods, and you can affect the result by 
selecting the most suitable one for your application: 

⚫ Minimum edge length method will allow you to set the minimum edge 
length to be left in the model, all triangle edges shorter than the given 
minimum edge length are removed.  

⚫ Maximum number of triangles method will remove triangles until the 
number of triangles reaches the given maximum triangle count.  

⚫ Maximum deviation from the original surface will remove all triangle 
edges which do not cause the surface points to move more than the given 
maximum deviation.  

Whichever method is used, the triangles are reduced so that the given limits are 
respected. Anyhow, the command does not reduce triangles so that erroneous 
geometry would be generated (i.e., non-manifold geometry with more than two 
triangles at an edge, overlapping triangles etc.).  

The limits for the reduction method are given in the Main filters group. Each 
reduction method has its own Main filter which must be used with the method. 

⚫ Edge length filter will set the minimum edge length remaining in the 
reduced model for Minimum edge length method.  Maximum length 
multiplier sets the upper limit to the edge length change during the 
reduction, this is important when producing triangles for simulation 
applications which require a good triangle aspect ratio. Note: With Minimum 



3Data Expert 14.1: Tutorial 1 - Working with 3D Models  

 Page 95 

edge length method you can, in addition to the basic Edge length filter, use 
Surface deviation filter to have even more control over the surface shape 
change.  

⚫ Number of triangles filter will give the maximum triangle count allowed 
in the model after the reduction.  

⚫ Surface deviation filter will give the maximum distance of the reduced 
surface from the original surface with the maximum deviation limit. 

Geometry feature filters will add special rules to preserve the geometric features 
in the model, i.e., the surface edges and triangle normal directions.  

⚫ If Keep surface edges is set, the surface edges generated during the Auto 
Repair, Verify Shells or Repair Shells commands will be respected and not 
deleted from the model. Triangles can be reduced along the edges but not 
over the edges, effectively preserving at least a few triangles from each 
surface in the model. Also, sharp corners at open edges (at the gap curves) 
are preserved within the user defined limit, all corners sharper than the 
given limit are kept. For example, a square with 90-degree sharp corners 
will remain a square after the reduction with the default 135 degrees sharp 
open edge angle limit (90 < 135).  

⚫ Triangle normal direction change will limit the change of triangle normal 
to the given degree value. This will very effectively prevent large changes 
in the model shape. For example, if a cylindrical hole needs to be reduced 
to minimum number of triangles (i.e., a triangle shaped hole), you must 
increase the maximum change angle to 45 degrees or more, by default 
only 10 degrees changes are allowed, therefore cylindrical holes may 
remain densely triangulated.   

Color and texture feature filters will add special rules to preserve the textures 
and colors in the model. These rules are similar to the rules applied to the surface 
edges above: triangles are not reduced over texture or color boundaries, but they 
may be reduced along a texture boundary. This will always leave a reduced 
representation of the texture (or color) area in the reduction result. Color and 
texture feature filters are particularly useful when reducing data for AR, VR or 
game applications. Sharp texture edge angle and sharp color edge angle work 
in the same fashion as sharp open edge angle above.  

Generally, the more filters you are using, the less reduction may happen and the 
longer it may take to run the command. On the other hand, filters are very important 
for preserving desired features in the model.  

 

Reducing the rava2 model 

Now let’s try to reduce the rava2 model with the default parameters. Drawn as 
wireframe and shaded, the original model looks like this (with a close-up on the 
right): 
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For reduction, you can make sure the default parameters are in use by  

− pressing the Defaults button in the dialog. 

− Then press OK button.  

You will soon see the result with 71,3% reduction: 

 

If you compare the detail in the original model with the reduced model, you can 
see that the geometric features are very well kept while a serious reduction is 
applied to the model.  

The model still looks the same but now there are only 1628 triangles left from the 
original 5674 triangles. 

Generally, there are no edges shorter than 1.0 units left in the model anymore. The 
new edges originally shorter than 1.0 units are now between 1.0 and 2.0 units 
(1.0*upper limit multiplier = 2.0).  
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Let's try another reduction with a bigger minimum edge length.  

− Press Edit -> Undo Reduce and then 

− Modify Faceted -> Reduce again and set the minimum edge length to 
2.0 as seen below:  

 

Then press OK 

and after a short while you will see the result with 82,5% reduction:  

 

You can clearly see how more triangles are reduced from the mesh and still the 
model shape remains accurate.  

There are some areas where you can still find triangles with shorter edges than 
2.0 mm, as seen here (note the small green bounding box in the top-right corner):  
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These areas are due to small one triangle surfaces in the original model (in green 
bounding box above), Keep surface edges filter prevents us from deleting any 
surfaces fully from the model. To remove minor surfaces like this we can make 
another run with the minimum edge length 2.0 units but  

− turn Off the Keep surface edges filter, as seen below: 

 

− press OK to rerun the Reduction. 

 

This will produce another 18,1% reduction by removing some small surfaces 
altogether.  

 

 

Let's now try the other reduction methods.  

− Press Edit > Undo until you have the original rava2 (Verified) model 
available again (here in shaded + wireframe display mode). 
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Then give the Modify Faceted > Reduce command 

− press the Defaults button and give the following parameters  

− reduce to maximum 1000 triangles:  

 

− Press OK to see the following result with 82,4% reduction and 1000 
triangles: 
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There is still one method to go, Maximum deviation from the original surface. 

− Give Undo command, then 

− start Reduce and give the following parameters after pressing Default 
button:  

 

Now the maximum allowed distance of the resulting surface is 1 mm from the 
original surface.  

− Press OK and you will end up with 92,5% reduction and 428 triangles: 

 

 

Which reduction method to use? 

As you can see, there are different ways to get to a reduced result, depending on 
the requirements defined for the result. Generally, Minimum edge length method 
should be used if a reduced triangulation with evenly shaped triangles is required. 
Maximum number of triangles method should be used if there is some definite 
upper limit to the triangles accepted for the receiving application. Maximum 
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deviation from the original surface should be used if keeping the model shape 
is the most important requirement; some simulation systems as well as 3D printing 
applications may require that.  

 

Improving the triangle aspect ratio 

The triangle reduction command can also be used to create a triangle mesh with 
a better aspect ratio, i.e., to remove very thin triangles from the mesh. This is an 
important feature for some simulation applications, because better-shaped 
triangles will generate more accurate simulation results. A better aspect ratio is 
achieved by combined use of the Modify Faceted > Refine and Reduce 
commands.  

We will start this exercise by  

− reopening the rava2.stl file and 

− running the Auto Repair on it through the Operation Mode Fix Model 
button. Then repeat the first reduction done in the chapter Reducing 
rava2 model (i.e., press Defaults button) 

− Select the 1. rava2 (Verified) shell in the Model Tree,  

− give the command Modify Faceted > Reduce and press Default 
button in the Reduce parameter dialog.  

− The press OK to get the first reduce result:  

 

We have now removed excess triangles from the mesh. We will next run the Refine 
command to generate new triangle corner points into the mesh. These new points 
will be used to create new, evenly shaped triangles during the next reduction run.  

First you should estimate the minimum size of the triangles you would like to see 
in the resulting mesh. Let's assume we want to use triangle size of approximately 
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1.0 mm. In this case we will first refine the mesh to maximum 1.1 mm edges and 
then reduce it to 1.0 mm edges to get to the desired result.  

− Select the rava2 (Reduced) shell from the Model Tree.  

− Give the command Modify Faceted > Refine, then fill in the following 
parameters (choose Edge length and set it to 1.1): 

 

− Press OK to start the Refine command, after a while you will see the 
following result on the screen (next page). 

The result now contains approximately 172 000 triangles. It is full of very thin 
triangles with bad aspect ratios. Anyhow, we now have a suitable set of new 
triangle corner points for further reduction, to generate new, evenly shaped 
triangulation (a close-up detail on the right).  

  

The refine result does not contain surface information in it. To be able to produce 
more accurate reduction results with the Keeps surface edge filter we must 
regenerate the surface edge information to the model. To do this you should 

− run the Fix Model > Repair Shells command with the following default 
parameters: 
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Also turn on View > Show Edge Lines to see the surface edges. 

After pressing OK you will see the shell subdivided to surfaces again and we are 
ready to simply  

− run the Reduce command on the rava2 shell with the Default 
parameters. 

After a while you will have the result with 78,6% reduction (you can run the result 
through Fix Model > Verify Shells to recalculate the edge lines). The result will 
contain approximately 37 000 triangles. If you look closer, the triangle mesh is well 
shaped all over the model ensuring accurate simulation results: 

  

 



3Data Expert 14.1: Tutorial 1 - Working with 3D Models  

 Page 104 

If you wish to get even less triangles but to keep the good aspect ratios, just rerun 
the Reduce command with a bigger minimum edge length value. For example, 
value 5.0 gives the following result of further 93.6% reduction with approximately 
2300 triangles:  

 

For the last reduction, you would achieve optimal results if you would use Edge 
length value 5.5 mms in the first Refine but this example shows that you can use 
very strong edge reduction on any kind of model and still get good results for 
simulation applications.  

 

Conclusions 

Thank you for going through these Tutorial lessons for 3Data Expert software. You 
can now use the 3Data Expert software modules for everyday 3D printing work or 
prepare surface and STL data for simulation software packages.  

The 3Data Expert software contains a vast number of features not covered in this 
document. Please refer to the On-line Help and its examples for more information 
on the available functionality.  

To learn more about the use of the STL and VRML handling available in the 3Data 
Expert software, please have a look at the advanced repair document: 3Data 
Expert 14.1: STL and VRML repair examples. This document is available through 
the Help > Tutorial Documents command and the demo files are stored in the 
Tutorials / GeomFiles directory under the software installation directory.  

We hope you will have a productive time with the DeskArtes 3Data Expert software 
in your everyday data preparation work. If you have any questions or comments 
on the use of the DeskArtes software products or this manual, do not hesitate to 
contact us at support@deskartes.com. 
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